PHP is one of the most widely used server-side programming languages. It’s extremely popular since it is free software, which you can use to develop interactive sites such as community web portals, e-stores or online learning sites instead of static HTML sites. A PHP module should be available on the server where a PHP website is hosted so that its source code can be read. Because there aren’t any license fees for this type of module and the language offers countless options for the web-based apps that you create, there’re hundreds of millions of PHP-powered sites. On top of that, there’re an enormous number of open-source PHP-based scripts, which you can use for your sites without the need to possess any programming experience. Since there’re different versions of PHP, you must verify that the very same version that you used while setting up your site is enabled on the server as well.

PHP 4 and PHP 5 Support in Cloud Hosting

We have decided not to prevent our current and potential clients from choosing what PHP version will be used by their websites, which goes to say that in case you buy a cloud hosting plan from our company, you’ll be able to choose between versions 4, 5.2, 5.3, 5.4 and 5.5, not only for the web hosting account in general, but also for each individual domain that you host. This can be accomplished with just one single click of the mouse through our in-house developed Hepsia Control Panel via which all shared hosting accounts are administered, which is why you won’t need any technical or coding capabilities. You will be able to run websites built with both new and old scripts without having to overcome any obstructions, so if you’d like to change your current web hosting supplier and move over to us, you can be certain that all the sites that you’ve developed over the years will continue to run correctly.

PHP 4 and PHP 5 Support in Semi-dedicated Servers

If you have a site created with an older version of PHP and you’ve invested time and effort in setting it up, fixing security gaps and posting content, you will need a hosting service that can support it, since the vast majority of hosting companies nowadays offer only the newest version of PHP and give up the older ones. We, on the other hand, have decided to let you select the version that your own sites require. Our semi-dedicated hosting plans support PHP 4 and multiple versions of PHP 5, which implies that you will be able to run both newer and older scripts without losing any manual settings or wasting time striving to make your sites compatible with the web hosting environment. The current version can be changed via the Hepsia hosting Control Panel and such a change will affect the whole semi-dedicated account, but you’ll also have the ability to choose a different version of PHP for each individual website hosted in your account by means of an .htaccess configuration file.